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Description 

 
This guide explains what the Signage possibilities are in Manage for TEOS and how to use 

its Content Creation and new style Content Creation (Beta) section.  
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Requirements 
• Manage for TEOS 3.3 when using the new style Content Creation (Beta) 

• Internet access (optional) and ssl/https certificate for external data access. Please 

refer to the technical requirements document for more details 

• Please refer to the release note of your Manage for TEOS version to use the 

appropriated versions into the devices 

• Web page access  
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1. Introduction of Signage in TEOS  
 

1.1 Key features  
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1.2 Signage Full Creation workflow 

 

1.3 Signage user workflows  

 

1.4 Administrator view for Content Creation 

Under ‘Content Creation > Templates’, you can create many different types of elements and 

place them anywhere on the template. Philosophy for the template creation is to create 

pages that are dynamic by connecting external data which is updated without user 

interaction. 
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Content 

Content creation Yes (basic mode and advanced), basic only for the SMB Cloud version 

Main functions 
Template design, playlist creation, presentation management, device 
management 

Monitoring Yes (live preview on device) 

Content scheduling Yes (per device, per group, support for recurrency) 

Content creation elements 

Text, Image, Video (one per page), Rectangle, Web Browser, Ticker Tape, 
Date/Time, (YouTube (one per page), Vimeo (one per page), Audio, 
Slideshow, QR Code, Meeting Room, Mirroring (TEOS Connect), Power BI 
(Dashboard, Report, Tile) and Table. PDF and PowerPoint can be converted 
to images. 

Emergency alarms Yes (using TEOS Manage or URL) 

Basic signage via email Yes (PowerPoint attachment converted to slideshow) 

User management for content Yes (per user or group) 

Custom resolution Yes 

Content orientation Portrait/Landscape 

Content display method Downloaded from server, stored on device, external data using data source 

Data 

Statistics Yes (from Dashboard, Proof of Play) 

Content log Yes 

External data integration 
Instagram, Weather, Power BI, RSS/XML, Microsoft 365 (Office), Google 
Calendar, Exchange, TEOS Calendar, Scienta and Celcat 

Media upload 

Image: JPG, PNG, GIF (Full HD for tablet and 8 MP for BRAVIA) 
Video: (MP4 only, BRAVIA: up to 4K@60Hz at 40 Mbps in Landscape and 
Full HD at 8 Mbps in Portrait, Tablet: Full HD at 8 Mbps 
PDF (converted to images) 
PowerPoint (converted to images) 
Audio: MP3 
Video Stream: Full HD at 5 Mbps (one per page) 

Touch interactive content Yes 

Compatible devices BRAVIA Professional Display, Android Player for TEOS, Tablet for TEOS 

 

1.5 New content designer (beta) 

When using Manage for TEOS version 3.3, we also offer to use our newly developed content 

designer (currently in beta) for creating content. Go to ‘Content Creation (Beta) > Pages’ to 

give it a try. 

 

Content 

Content creation Yes 

Main functions 
Template design, playlist creation, presentation management, device 
management 

Monitoring Yes (live preview on device) 

Content scheduling Yes (per device, per group, support for recurrency) 

Content creation elements 
Image, Text, Shape, Video (incl. YouTube, one per page), Ticker Tape, 
Date/Time, Web Browser, QR Code, Power BI, Audio, Slideshow, Table and 
PowerPoint (converted to images). 
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Emergency alarms Yes (using TEOS Manage or URL) 

Basic signage via email Yes (PowerPoint attachment converted to slideshow) 

User management for content Yes (per user or group) 

Custom resolution Yes 

Content orientation Portrait/Landscape 

Content display method Downloaded from server, stored on device, external data using data source 

Data 

Statistics Yes (from Dashboard, Proof of Play) 

Content log Yes 

External data integration 
Custom (RSS/XML), Weather, Facebook, Instagram, Power BI (Dashboard, 
Report, Tile), Microsoft 365 (Office), Google Calendar, Exchange, Zermelo, 
NS Info and RealWorks 

Media upload 

Image: JPG, PNG, GIF (Full HD for tablet and 8 MP for BRAVIA) 
Video: (MP4 only, BRAVIA: up to 4K@60Hz at 40 Mbps in Landscape and 
Full HD at 8 Mbps in Portrait, Tablet: Full HD at 8 Mbps 
PDF (converted to images) 
PowerPoint (converted to images) 
Audio: MP3 
Video Stream: Full HD at 5 Mbps (one per page) 

Touch interactive content Yes 

Compatible devices BRAVIA Professional Display, Android Player for TEOS, Tablet for TEOS 
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2. Signage capabilities in Manage for TEOS 
TEOS Web platform propose you an interface with an extensive choice of elements to create 

your content. From a simple image and text, to an external data source, a PowerPoint import, 

YouTube and more. This section will explain all the possibilities you can get thanks to Signage 

for TEOS and content creation features into TEOS.  

To create Signage content in Manage for TEOS platform, there are three workflows: 
- Basic (basic signage mode) 

- Complete (complete signage mode) 

- Simplified (using the new content designer [beta]) 

These three workflows are explained below. 

  

2.1 Configuration of the signage mode  

You need to set up your Manage for TEOS installation with the way you want. 

If you want to use the easy workflow go to Server Management 

   

and in the settings, in the Content creation settings,  

 

 

select Use basic signage mode and save. 

 

2.2 Access rights   

All the content upload or created from Manage for TEOS platform is by default the property 

of the user that creates it. A user can share the content with another user or a group of 

users. To do this, in all the different content created, the user can find the icon below:  

    

When pushing the user right logo, this 

pop-up appears. You can apply inherit 

rule to all the content if you have folders 

By pressing the group name or username, you are 

giving the access to view, edit and remove the content 

by the others. If you press on one of the logos, you will 

remove the access one by one.   
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2.3 Complete signage mode explanation   

Before you start creating a presentation, the following scheme explains the ‘Complete’ 

signage content creation workflow: 

 

2.4 Basic signage mode explanation 

The ‘Basic’ workflow combines Templates and Pages on the same level and the Playlists 

and Presentations on the same level: 

 

The Presentation represents the final content you would like to display on a 

screen or multiple screens: 

 The Presentation itself is made up out of one or multiple Playlists 

 A Playlist contains Pages 

 These Pages are based on Templates 
 

Your corporate identity is guaranteed in the Masterpage. This special template holds your 

company logo and elements in your corporate style and/or colours. 

Basic signage mode is enabled by default. The SMB Cloud version of TEOS does not 

support Compete signage mode. 
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2.5 Simplified signage mode explained 

With the ‘Simplified’ workflow using the new content designer (beta), there are only Pages 

and Playlists. A page may contain an optional foreground and/or background page (function 

similar to a Masterpage). A Playlist may contain other Playlist(s) too and represents the 

whole ‘Presentation’: 

 

2.6 Signage elements using the Basic/Complete signage mode 

To create content, you have access to a variety of elements to play with when on the 

creation page. Those elements are listed below with a quick description: 

 

 

Selection tool Use the selection tool to select an element from your presentation. 

 

Media uploaded used in content creation 

 
Text element Use the text element to add text. The dialogue box will ask you to 

enter a name (your own description) and text. The [Formatting] tab 
allows you to enter the font, size, colour, style and transparency.  
A new option from version 3.0 has been introduced which is called 
the text transform for the solution to automatically adapt the text 
size if you have dynamic content.  

 

 
Image element The image element allows you to add images. The dialogue box will 

ask you to enter a name (your own description). On the 
[Formatting] tab, you can select measurements and transparency; 
choose whether to keep or to change the current ratios; and select 
the appropriate alignment. 
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You can upload one from your computer on the ‘Data’ tab by 
clicking [Add file(s)].  Once you have added files, you must click the 
[Start upload] button. The image will then appear in your media 
library.  

 
Video element The video element allows you to add a video that has been 

uploaded from your local file, or, alternatively, you can insert a 
Streaming URL in order to display live images of a camera (for 
example). You can do this by selecting a video on the ‘Streaming’ 
tab. The ‘Data’ tab allows you to select or upload videos. You can 
upload videos from your computer on the ‘Data’ tab by clicking on 
Add file(s). Once you have added files, you must click the Start 
Upload button. The video will then appear in your media library. 

 
Graphics 
element 

Use the graphics element to draw items in your template or master 
page; it is used, for example, to draw a background behind a ticker 
tape. You can select a colour from the Layout tab. 

 
Audio element Use the audio element to add single sound files or add an audio 

stream. TEOS is compatible with MP3 files  

 
Help element Help option can be used as an interactive option in order to show 

an element by pressing the help button and hide it when pressing 
again. The help element will get an image and the element to be 
hidden needs in the element name a “_” underscore to link it with 
the help button  

 

Ticker tape 
element 

The ticker tape element allows you to add a scrolling text overlay 
(crawler). The dialogue box will ask you to enter a name (your own 
description). The Layout tab allows you to enter the font, size, 
colour, style and transparency.  
Additionally, you can enter your own text in the ‘Data’ tab. 

 
Slideshow 
element 

It’s very easy to create an image slideshow using the Slideshow 
element. By linking to images from the image database, you can 
compile your own image sequence.  
You can also set the interval between slides and choose to make 
the images semi-transparent. 

 

PowerPoint 
element 

From within a Masterpage or template, you can easily upload your 
PowerPoint files.  
Manage for TEOS will automatically detect the number of pages 
and will ask you if you want to use them as single images (by using 
the slideshow element) or as a video file. 

 

Elements with external datasources 

 

Ticker tape 
element 

In addition, you also have the option to retrieve the text from an 
external data source, for example NOS [Netherlands Broadcasting 
Foundation].  
To do so, you must click on the ‘Data’ tab and, under External data, 
select the data source you would like to use.  
To create data sources, you must read the instructions contained in the 
’External data’ section of this manual.  
 
Additionally, you can enter your own text in the ‘Data’ tab. 

 
Text element You can also retrieve the text from an external data source, for 

example CNN. To do so, click on the ‘Data’ tab, and under [External 
data], select the data source you would like to use. The ‘External data’ 
section in this manual explains how to create data sources. 

 
Image element You can upload one from your computer on the ‘Data’ tab by clicking 

[Add file(s)].  Once you have added files, you must click the [Start 
upload] button. The image will then appear in your media library. You 
can also retrieve images from an external data source, like Yahoo 
Weather. 
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To do so, click on the Data tab, and under [External data], select the 
data source you would like to use. For instructions on how to create 
data sources, check the ‘External data’ section in this manual. 

 
Table element Using text type from external datasources, you will be able to create 

your table in TEOS taking the different rows available in your datafeed. 
To finalize you must select the number of columns and create the 
layout with fonts and text colors you want to use.   
Table will be filled with the data from the external datasource 

 

 
Power BI 
element 

Add a Power BI dashboard, a report or a tile into your template using 
the Power BI external data source. In Manage for TEOS Server 
settings you add can authenticated accesses in Power BI using a 
Tenant ID and Secret code  

 

Streaming compatible Elements 

 
YouTube 
element 

The YouTube element allows you to add YouTube videos – for this 
you require the URL or code for your video. For example, you can 
copy the URL from your browser.  
You must then paste the YouTube code/URL onto the ‘Data’ tab 
and decide whether you would like to play all or part of the video. 

 
Vimeo element Same as Youtube only for Vimeo. 

 
Video element Under the video element you can also choose the live streaming, 

here you can put your stream URL. TEOS is compatible with 
RTMP, HLS, UDP Multicast.  

 
Audio element Use the audio element to add single sound files or add an audio 

stream. TEOS is compatible with http  

 

Element using an external web URL  

 Website element The website element allows you to display a website. You must 
enter the complete URL on the ‘Data’ tab.  
You can select ‘Reload’ as an additional option; the page will then 
be refreshed each time (TEOS reloach the embedded web browser 
each time the page need to be displayed) 
From version 3.0 a new functionality has been introduced for the 
authentication of some pages where authentication is with NTLM 
method 

 
QR element Signage Manage for TEOS allows you to create QR codes within 

your templates and pages. Simply select the QR Code element tool 
and draw the size of your QR Code element which you prefer.  
Keep in mind that a QR Code element will always be square; which 
means you aren’t allowed to change its measurements .  
Once you have placed the element on your template, you now only 
need to fill in the URL which you want to trigger when the QR Code 
is being scanned. 

Element from TEOS device or TEOS Database 
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Date/time 
element 

The date/time element allows you to add a date and/or time. On 
the Layout tab, enter the font, size, colour, style and 
transparency.  
The Data tab allows you to select the format, HH:MM:SS or DD- 
MM-YY. In the device, the date/time shown is coming from the 
device  

 
Meetingroom  
element 

Be able to put in your signage interface Meeting room details 
such as room name, next meeting time etc 

 

 
Mirroring 
element 

Using Connect for TEOS in background and Signage for TEOS 
app, get from the device in your signage interface the IP address 
of the device shown in the interface, the SSID of the device, 
password of the SSID and device Name  

 

Optional Elements (not enabled by default in TEOS Platform) 

 

TV element Show source of your TV. Only html5 not Android (End of life) 

 
Playlist Element This feature will allow you to add a playlist into your template. The 

playlist template can use the playlist duration, or the playlist will be 
show only during the template/page duration in the other playlist 

 

2.7 Create a Masterpage 

Masterpages are pages containing specific elements, for example a news ticker tape that must 

appear on every page of the presentation. You might describe it as a layer that is applied 

across all the pages of the presentation. An example of the application might include: 

 

You would like to use the same background using an NOS news ticker tape throughout your 

presentation. You can then create a masterpage by navigating to [Content > Master pages] in 

Manage for TEOS Signage Designer and clicking the “New Masterpage” button. 
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A new screen will now appear where you can enter the name of your masterpage and select 

the required resolution. 

 

Next, a screen will open on which you can select elements, for example a background image 

and a ticker tape. 

 

2.8 Create a Template 

 

In the Designer, click ‘Content’ and then ‘Templates’. In the template section, click on New 

template. 

 

 
Enter the name of the template you would like to create, select the required resolution and 
click Save. 
 
The following screen will appear:
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In the template designer, you can select one of the elements that appear in the menu bar. 

 
If you click on the element you would like to place in the template, use your mouse to start 
drawing in the white window by left-clicking on your mouse and drawing the required 
dimensions. Once you have completed this, a window will open: (we have drawn an image in 
this example). 

 
You must enter a number of data in the window, including the image name. This name must 

be understandable to you and will not be displayed in the final presentation (only on the 

overview of elements on the left-hand side). 

 

The Layout tab allows you to select a number of options relating to how the element is 

formatted. For images, you have the following options: 

- Stretch; Fill: [Ratio is not maintained] 
- Stretch; Uniform [Ratio is maintained] The option Stretch; Fill is selected by default. 

 

From the ‘Data’ tab, you can select a previously posted image, or, alternatively, you can upload 

one from your computer by clicking New upload. Next, click on the image to select it and then 

click on Save to insert the image. We have added a second image to the example (on the left-

hand side), called ‘Image’. 
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Next, in the template we can select, for example, a text element and add this: 

 

The template is almost ready for use; we might still choose to add a ticker tape showing CNN 

news items. As explained above, we can use a ticker tape to be used on the master page or 

we can insert it into this template. For now, we are going with the second option. 

 
Click on the ticker tape element and draw a ticker tape in the black bar at the bottom. Next, 

give the element a name, for example ‘CNN ticker tape.’ On the Formatting tab, select font 

size 60 (this is standard) and the colour white. On the ‘Data’ tab, select CNN and ‘title’ as the 

column, then click Save. The title column from the CNN RSS feed is now displayed, in white 

and with a font size of 60. Click on Save at the top of the page – your template is now ready 

for use. 

 

2.9 Create a Page based on your template  

 

Pages are based on templates. You can use one of the predefined templates for this purpose, 

or, alternatively, you can use a customized template. In this example, we use the “manual” 

template. To create a page, click on Content > Pages in Manage for TEOS Signage Designer 

and then on New page. 

 

A screen will appear in which you must enter the name of the new page. In this page we will 

use the name My first page. Select a template and click Save. 

 

The next page will open: 
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By clicking on an element on the left-hand side, under Elements, you can make changes to 

your text or images. However, you can no longer change the positions of the elements – this 

is possible only in the template. Once you are done editing a page, click Save. 

We would now like to add our page to a playlist; to do this, you have 2 options:  
- If your playlist is already existing, you can press on the button “add to playlist 

 
By clicking in this button, you will be able after to see the list of playlists and add the page 
directly to the playlist. You can see as well in this pop-up the playlist attached if the page was 
already used 

 
 

- to go to the ‘Playlists’ section, from that part you will be able to create a playlist if it is 
not, and you can as well change the time and the positioning of your page in the playlist 

 

2.10 Create a Playlist with Pages 
Playlists contain pages including information you would like to display on screens. A final 
presentation may contain multiple playlists, for example if you have installed a screen in the 
cafeteria and would like to display the menu along with general information. In that case, you 
can select a playlist containing both general information and menu information, in order to 
prevent menu information from being displayed on screens where it does not belong. To create 
a playlist and add pages, you must click on Content > Playlists in Manage for TEOS Signage 
Designer and then on New playlist. 
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You enter the name of the playlist, select the required resolution and click on Save. 

 

A new screen will appear displaying all the pages that are available in the same resolution. 

 
Next, click on the page you would like to add, then click on Add to timeline. 

The page will now appear below at the bottom of the timeline. You can select the duration by 

dragging the page on the right-hand side to the right. For example, if you would like to display 

the page on the screen for 20 seconds, you should drag the page (enlarged) to 20 seconds, 

or, alternatively use the ‘-’ and ‘+’ buttons. Once you have added the page(s) required, click 

Save and continue to the ‘Creating presentations’ section. 

 

 

From the playlist page you can directly link it to a presentation if your presentation is created. 

For that you have 2 options.  

From the list view of the playlists, you can press on the line “used in X presentation” and link 

then your playlist to your presentation  

 

You can has well see where your playlist is linked from this pop-up  
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The other option to add a playlist in a presentation is directly from the playlist by pressing in 

the “add to presentation” button and get into the same pop-up where you 

can link your playlist or check where your playlist is linked 

 

2.11 Create a Presentation (in Signage tab) with your one or more playlists  

You should now have all the ingredients to create a presentation, namely: 

1. A template 

2. A page 

3. A playlist 
Go to Workplace management > Signage  

 

 

 create a new Presentation  

 

Enter a name for your presentation and select a resolution. If you have created a masterpage, 

select the appropriate masterpage from the menu. 
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Next, select a playlist in our case, this is My first playlist. Click the + symbol and select a playlist: 

Your content is almost ready for use; all you need to do is send this content to a device 

 

2.12 Upload media content  

Media content can be uploaded directly when adding a new element into a masterpage and 

templates or can be also added by uploading it into the Media Upload interface. In both case 

the content will be shown into the Media and Data > Media upload tab.  

In this interface, the content can be drag and drop to a folder, and the content can be shared 

with other users or user group of the platform thanks to the rights buttons. 

 

 

2.13 Add external data sources  

For external data, you can provide feeds of external sources, including RSS feeds, XML 

feeds or Twitter feeds. RSS feeds are often used to provide content for third-party programs 

without formatting. You might also have HR software that lists your employees’ birthdays in 

XML, allowing you to easily display data on your screen. 

 

To add a feed click External data and then New datasource in the top right of this tab: 

 

In this example, we will add an RSS feed from CNN 

(http://rss.cnn.com/rss/edition_world.rss). First, we name our data source CNN and then 

select RSS/XML: 

Buttons create a new folder, 

upload a media from the PC and 

user rights 

In each file, you can see the 

content, remove the content or 

define a user right 

http://rss.cnn.com/rss/edition_world.rss)
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Click Next and the following appears: 

 
 

Fill out the URL for your RSS/XML feed. Should the feed require Windows authentication, 

you can also fill out the username and password here. When you are done, click Save. The 

external data source is now set up and appears in your overview: 

 

From here, you can click the icons in front of the feed to edit your feed: 

 Edit - Lets you view and/or edit what you have entered in the above steps. 

 Delete - Deletes your data source from the Designer. 

 View - Opens a new browser tab to show you the data in the specific feed. 

 

 

2.14 Add a new Resolution 

You can have a variety of resolutions used for your signage content. The default resolutions 

are: Full HD (1920 x 1080), Full HD Portrait (1080 x 1920), Widescreen (1600 x 900), 

Widescreen Portrait (900 x 1600), TEOS Book (1280 x 800) 

You can create new resolutions if needed, for that, go to Content Creation  

Go to the Resolutions section 

  

Click on Add Resolution. Give it a name, dimensions and save. 
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It appears at the end of your resolutions list. You can change its preferred location by 

dragging it up or down with the line icon on the left. 

2.15 Signage elements using the Simplified signage mode (beta) 

To create Signage content, using Manage for TEOS 3.3, you can also use try our newly 

developed designer, go to ‘Content Creation (Beta)’. When creating a page you can use the 

following elements to design your page. These are listed below with a short description. 

 

Selection tool Use the Selection tool to select an element 

  

Page Elements 

 
Image element Use the Image element to add an image. Use the Image properties 

pane on the right to select or upload an image from the Media 
library. For its content, this element can also be linked to a data 
source.  

 
Text element Use the Text element to add a text box. Use the Text properties 

pane on the right to define the font and style of your text. For its 
content, this element can also be linked to a data source. 

 
Shape element Use the Shape element to quickly add a shape (Ellipse, Rectangle, 

Triangle, Polygon, Star and Arrow) to your page. Use the Shape 
properties pane on the right for more options to define the shape. 

 
Video/YouTube 
element 

Use the Video/YouTube element to add a video file. Use the Video 
properties pane on the right to select or upload an video from the 
Media library. Options to mute or loop the video are also available 
here. For its content, this element can also be linked to a data 
source (Video only, not for YouTube). When using a YouTube 
video, you can also define the start and end time.  

 
Ticker Tape 
element 

Use Ticker Tape element to add a Ticker Tape. Use the Ticker 
Tape properties pane on the right to define the speed, gap, 
direction and separator character. For its content, you can use the 
Text properties pane (incl. linking it to a data source). 

 
Date/Time 
element 

Use the Date/Time element to quickly add a date and/or time to 
your page. To define the format, you can use the Text properties 
pane. 

 
Web element Use the Web element to add a website to your page. Use the Web 

properties pane on the right to define the URL. Please be aware not 
all websites allow this. For its content, this element can also be 
linked to a data source.  

 
QR Code 
element 

Use the QR Code element to quickly add a QR Code to your page. 
Use the QR Code properties pane on the right to enter text data the 
QR Code should represent (URL is also supported). For its content, 
this element can also be linked to a data source.  

 
Power BI 
element 

Use the Power BI element to add Power BI content, such as a 
Dashboard, Report or Tile to your page. A Power BI data source is 
required. 

 
Audio element Use the Audio element to add audio (MP3). Use the Audio 

properties pane on the right to select or upload an audio file from 
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the Media library. Options to mute or loop the audio are also 
available here. 

 
Slideshow 
element 

Use the Slideshow element to quickly add multiple images in one 
slideshow on your page. Use the Video properties pane on the right 
to select or upload images from the Media library. After adding the 
images, you can set the image duration and transition. For its 
content, this element can also be linked to a data source. 

 
Table element Use the Table element to add a table. Use the Table properties 

pane on the right to define the table columns and rows. For its 
content, this element can also be linked to a data source. 

 
PowerPoint 
element 

Use the PowerPoint element to add a PowerPoint to your page. 
Use the PowerPoint properties pane on the right to select or upload 
a PowerPoint file from the Media library. You can also set the 
image duration from here. 

 

2.16 Create a Page (optional as background/foreground page) 

As explained in 2.5, with the ‘Simplified’ workflow using the new content designer (beta), 

there is no ‘Masterpage’. However, you can create a page and use that page as a 

background or foreground page within another page, this will mimic the usage of a 

‘Masterpage’ as known from the Basic/Complete signage mode. 

The background/foreground page is a page containing specific elements, for example a news 

ticker tape that must appear on every page of the presentation. You might describe it as a 

layer that is applied to the page. An example of the application might include: 

 

You would like to use the same background using an NOS news ticker tape throughout your 

presentation. You can then create a foreground/background page simply by creating a page 

by navigating to [Content Creation (Beta) > Pages] in Manage for TEOS and clicking the ‘Add 

new page’ button. 

  

A new dialog window will now appear where you can enter the name of your page. 

Next, a screen will open on which you can select elements, for example a background image 

and a ticker tape. 

After saving the page, this page can be used as a foreground/background page for a ‘regular’ 

page. To create a ‘regular’ page, just follow the previous steps to create a page.  
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To set a background/foreground page. Open the page and expand the Document properties 

to show the Background and Foreground. Select the content box on the right to choose a 

background and/or a foreground page.   

 

Content from a Background page will be placed behind the content of the page. Content from 

a Foreground page will be placed over the content of the page. 

 

2.17 Create a Page 

 

To create a page reating a page by navigating to [Content Creation (Beta) > Pages] in 

Manage for TEOS and clicking the ‘Add new page’ button. 

  

A new dialog window will now appear where you can enter the name of your page. 

The following screen will appear: 



24 | Signage for TEOS – Installation & User manual 

 

In the page designer, you can select one of the elements that appear in the icon bar on the 

left. 

If you click on the element you would like to place in the template, use your mouse to start 
drawing in the white window by left-clicking on your mouse and drawing the required 
dimensions. Once you have completed this, the image properties are available on the left side 
of the screen: (we have drawn an image in this example). 

 

 
 
In the Layers properties you can name the image element. This name must be understandable 

to you and will not be displayed in the final presentation (only on the overview of elements on 

the right-hand side). 

 

The Image properties pane allows you to select a number of options relating to how the 

element is formatted. For images, you have the following options: 

- Stretch; Fill: [Ratio is not maintained and element is filled with image] 
- Stretch; Contain [Ratio is maintained and element is contained with image] (default selection) 
- Stretch; Cover: [Ratio is maintained and element is covered with image] 
- Stretch; None: [Ratio is maintained and element is using the image in its original size] 

 
To select an image, click selector in the Image properties: 
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This will open the Media library. From here you can upload a new image, after uploading you 
can double click the image to insert the image into the element. 
 
We can add some text and a line (using the Shape element): 
 

 
 
The page is almost ready for use; we might still choose to add a ticker tape showing CNN news 

items. As explained above, we can use a ticker tape to be used on a background/ foreground 

page or we can insert it into this page. For now, we are going with the second option. 

 
Click on the Ticker Tape element and draw a ticker tape at the bottom. Next, give the element 

a name, for example ‘CNN ticker tape.’ In the Colors properies, select the colour white.  

 

To use an external data source for the ticker tape, in the Text properties, select the dropdown 

arrow next to the text input field to select the data source ‘CNN’ and ‘title’.  

 

 

 

The title column from the CNN RSS feed is now displayed in white. Your page is now ready 

for use. 

 

2.18 Create a Playlist with Pages 
Playlists contain pages including information you would like to display on screens. A playlist 
may also contain another playlist, for example if you have installed a screen in the cafeteria 
and would like to display the menu along with general information. In that case, you can select 
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a playlist containing both general information and menu information, in order to prevent menu 
information from being displayed on screens where it does not belong. To create a playlist and 
add pages, you must click on [Content Creation (Beta) > Playlists] in Manage for TEOS and 
then on ‘Add new playlist’. 
 

 

A new screen will appear displaying all the pages that are available. 

 

Next, click and drag the page(s) you would like to add.  

The page will now appear in the playlist. You can set the duration of the page on the right-

hand side of the page you added. Once you have added the page(s) required, click Save and 

continue to the ‘Creating presentations’ section. 

You can also add an already existing playlist to this playlist. Next to this, you can add media 

files from the media library and add page transitions in between pages.    

Your content is almost ready for use, all you need to do is link the this content to a device.  

 

2.19 Upload media content 

Media content can be uploaded directly when adding a new element into a page or can be 

also added by uploading it into the Media library. In both cases the content will be shown into 

the Media library. The option to connect to OneDrive and Dropbox is available. Default, it will 

show the content for TEOS Media that already is available through TEOS (Media and Data > 

Media Upload).   

In this interface, the content can be drag and dropped to a folder, and the content can be 

shared with other users or user group of the platform thanks to the rights buttons. 
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2.20 Add external data sources 

For external data, you can provide feeds of external sources, including RSS feeds, XML 

feeds or Instagram feeds. RSS feeds are often used to provide content for third-party 

programs without formatting. You might also have HR software that lists your employees’ 

birthdays in XML, allowing you to easily display data on your screen. 

To add a feed click Data sources, select ‘Custom’ from the dropdown and click the + to add a 

new data source: 

 

In this example, we will add an RSS feed from CNN 

(http://rss.cnn.com/rss/edition_world.rss). First, we name our data source ‘CNN’ and click 

‘Add’. 

The next screen will appear. For the Connection Type select ‘HTTP’ and fill out the URL: 

 

After this you can retrieve the data by clicking on the ‘Retrieve data’ button below the URL. 

Expand the ‘Choose your properties’ pane to open the data that is retrieved. From here, 

select the item you would like to be available in the designer.  
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Now, this item ‘title’ will be shown in the Data results of the data source. It is now available to 

select from when adding an element in the designer that supports a data source. 
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3. Add your device with Signage 
This section will explain quickly how to add a device that will show signage content. As it is 

described in other documents, BRAVIA with Android, Tablets for TEOS and Android TEOS 

Player can show signage content. Documents can be found in https://bit.ly/sonypsetech 

In Manage for TEOS, a signage license needs to be available.  

- On Manage for TEOS website go to Administration and Device Management.  

- There are 3 possibilities to add devices into TEOS: Import devices via Excel, device auto-
discovery, add It manually (explain in this document)  

- Press "add device" and:  

- Insert name of the device  

- Select "Display" or “Player” as device type 

- Select Sony as device brand 

- Model will be automatically field  

- Insert the IP address of the device  

- Select "Signage" as license type (license requested: TEM-DS30) 

- Add the device in a device group (create before a group in site configuration) 

- Press save 
 

Make sure your device is linked to the device group (meeting room type).  

 

Note: If the device Is not reachable via network, or you don't have license for It, you will get a 

message on top of this tab. If the device Is connected and the configuration done, you must 

be able to see It in green in both power status and behavior status. 

 

 

https://bit.ly/sonypsetech
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By pressing to the virtual remote, TEOS will do a first ADB request to your device. Device 

will after ask to allow the connection (debugging), for a security measure which needs 

to be done when the ADB connection is setup for the first time, you need to authorize the 

RSA key from the TEOS server, once this is accepted and saved into the local configuration 

file the connection can be setup at any time when the display is online. 

You will have to accept the connection by Manage for TEOS to be able to see the snapshot 

from the screen.  

Edit Delete  Execute command  Update screen 

 

When trying to install a new App in TEOS via Site Management > Service management, and 

in the device press test ADB, TEOS is doing the same request to the device. 

3.1 When using TEOS Cloud 

Go to your Manage for TEOS CLOUD Interface > Administration > Device management. 

We will add in this case manually a device to the cloud, for that press on the drop-down 

button on "Connecting cloud-controlled devices" to see the password automatically 

regenerated every 1 hour to insert in the device  

 

Now from the device, make sure it is connected to the internet. Open the app Cloud Control 

for TEOS (version 1.4.63 minimum) and insert the password, press connect.  

 

The device will then connect automatically to your cloud account without any additional 

action.  
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The ID shown in the device will appear in the AV device list after a refresh of the page and 

will be shown and this end of it. 

 

You can then setup it by clicking on the edit button:  

 

a) Insert the room or device name  
b) Select "Tablet" as device type  
c) Select Sony as device brand 
d) Model will be automatically field  
e) Select the license type 
f) Add the device into a device group (create before a group in site 

configuration) 
g) Press save 
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4. Display Signage content on your devices 
This section will explain how to link content to your device as a default presentation. The next 

section will explain, how to show content base on a scheduling.  

Go to Administration > Edit the device which will display the content 

 

Go to the sub-section Signage settings  

Specify the Rotation if the display is placed in portrait mode. Enable the checkbox “Always in 

Front” if you want the TEOS Android App to always force itself in front on the display, to prevent 

any other content to appear. Select a default presentation and create a schedule if desired. 

Afterwards, scroll down and click Save. 

  

 

 

 

When using the new designer (beta), change the Content type accordingly and click on the 

placeholder image to select content: 

   

TEOS Android App will 

automatically show up even if a 

manual action is done 

Select the Signage Presentation 

you have created Get analytics out of the Signage 

Content created  
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5. How to schedule Signage content 
This section will explain how to link content to your device or group of devices to a scheduled 

Presentation. In this case the device can go from the default presentation configured before 

to the scheduled Presentation.  

For that, go to Schedules & Alarms  

In the Content Schedule sub-section, drag your mouse on the timeframe chosen to display 

your content, Right click on it and select new schedule or you can directly press on the add 

schedule button  

 

Fill in the forms and save 

  

Select the device or the 

Device localization (group) 

Give a name to your schedule 

Select Start time and End time 

Select your signage content  

For Recurrence, you can select 

daily, weekly, monthly, yearly or 

every weekday when the content 

needs to be shown 
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6. Proof of Play & Content Log 
Proof of Play and content log feature are used to help the content creator to understand how 

the signage is used into the devices to take actions out of these stats. Content Log will show 

all the different operations done. Both propose filters to help in searching the information 

needed.  

Content Log:  

 

Content log using the new designer (beta):  

 

 
Proof of Play 

Proof of Play feature  gives you an overview on the usage of the signage content you have in 

order for you to be able to take action on the content that needs to be shown.  
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You can filter to get with more details the information you need to know  

  

Filter by player, by page, by 

playlist or by presentation in the 

time frame you need 
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